My 5513 is not consistent

Discussion in 'Rolex Watches' started by joeclark, Sep 13, 2017.

  1. joeclark

    joeclark

    TKF Newbie
    Joined:
    Jun 22, 2017
    Points:
    474
    Posts:
    237
    Likes:
    0
    Hello,

    I’ve had my 5513 service by a local watchmaker back in feb/16. But since then it’s been very inconsistent. Some days it’ll be -6sec, next day it’s -39sec and everything in between. I’ve taken it back to him twice. He had it on the time grapher, made adjustments on it in several positions, both times, but still experiencing the same issue.

    I take it to a different watchmaker, again, be puts it on the Timegrapher and he says it looks good too. He investigates further and suspects there might be insufficient lubricatant on the pallet fork jewels. He makes the nessesary adjustment and says it might not solve it without another full service.

    Alas, it didn’t really seem to solve the issues. This was about 6 months ago. Both watchmakers mention this being a vintage piece, it’s quite temperamental so it’s not uncommon for it to be like this.

    At this time, I was wearing this watch everyday, so it should have been fully wound and in multiple positions.

    What is everyones option on this? Vintage pieces are temperamental and leave it be? Does this need it be serviced again? Keep in mind, these two watchmakers are very reputable.

    Thanks,

    I didn't find the right solution from the internet.
    Reference: https://www.rolexforums.com/showthread.php?t=556039

    Sales Video Examples